ScrollBars not scrolling

Feb 22, 2012 at 4:28 PM

Hi, I'm trying out your GUI system for making a level editor. When I create a ScrollBars and add components to it, it will not scroll, the scrollbars do not respond to mouse input. When I run the starter kit, however, they work perfectly. Here is the code I am using, I am calling gui.Update() and gui.Draw() in the appropriate places, the button responds to the mouse but the scrollbars don't.

tileSetListScroll = new ScrollBars(5, 5, controlsWidth - 25, 150);

Panel p = new Panel(0, 0, 500, 500);
p.AddChild(new Button(0, 0, "button", delegate { }));
tileSetListScroll.AddChild(p);

controlsPanel.AddChild(tileSetListScroll);

gui = new RuminateGUI(game);
gui.SetTheme(new EmbeddedTheme(gui));
gui.AddElement(controlsPanel);
Feb 22, 2012 at 4:47 PM

Having done some more experimentation I've found that I can get the scrollbars to respond but only when they are added directly to the gui, without the intermediate panel.

Coordinator
Feb 22, 2012 at 8:56 PM

Yeah I found that last night as I was implementing some of the idea from the last 2-3 posts. got a little over zealous in my optimizing and starting cutting necessary logic. Anyways expect a new release tonight after I get home from work It'll be late though, probably after midnight.

 

So yeah my bad got lazy in my testing last release :(

 

Feb 23, 2012 at 12:08 AM

Thanks for the quick response, and impressive bug fixing time. I've made such mistakes before myself, totally understand. Looking forward to making use of your system, it'll save me a lot of time, which I'm rather short of.

Coordinator
Feb 23, 2012 at 4:01 AM

Should be fixed as of 1.0.6.

Feb 23, 2012 at 1:42 PM

Sorry but it's still happening, I'm running the same code and the scrollbars still don't respond. Also the button is now not positioned inside the panel, and does not respond to the mouse.

Coordinator
Feb 24, 2012 at 12:23 AM
Edited Feb 24, 2012 at 12:44 AM

Hmm I just re-downloaded 1.0.6 and the scroll bars seem to be working for all 3 downloads. Mind ziping up your project and sending it to me at scott.franks.1990@gmail.com? I'll try and take a look sometime this weekend.

Edit: Never mind I see the problem. 

Feb 29, 2012 at 2:23 PM

When do you think you'll have an update to fix this? I need to know whether to wait for it or try an alternative solution, I'm at a bit of a bottleneck.

Thanks for the help.

Coordinator
Mar 1, 2012 at 3:26 AM

Hopefully I'll release a fix over the weekend.

Coordinator
Mar 7, 2012 at 5:50 AM

Checkout 1.0.7 and give me a heads up if anything doesn't work.

Mar 7, 2012 at 7:41 AM

Seems to be working nicely, thanks.