This project is read-only.

TextBox deleting characters doesnt work properly?

Dec 7, 2012 at 4:59 PM
Edited Dec 7, 2012 at 5:55 PM


First of all I want to thank for such a nice easy to use gui. 

I have encountered something that I think is a bug. Might not be, maybe I'm just doing something wrong.

What I am doing is creating a text box: 

 TextBox AngleTextBox;

Later in initialize function, I set everything up:


       AngleTextBox = new TextBox(0,3) { Value = "" };
            Panel PanelAngleTextBox = new Panel(300, 10, 100, 35)
                Children = new Widget[] { AngleTextBox


Once I run, everything works and I can type stuff correctly, but when i try to get value sometimes it remembers some of the characters that I have deleted with backspace.

That's how I get a value:




for example I type in 3007, then delete with backspace three times until I get to the number 3 then type in 55.  The final value should be 355, but what the value I get returned is 3557.

Thank you again for the gui, it is great help, and my apologies in advance for spelling mistakes.


Dec 12, 2012 at 2:31 AM
Edited Dec 12, 2012 at 2:31 AM

Hey sorry to take so long to respond. I encountered this bug a while back. And though I fixed it. Are you using the nuget package? Because its a version behind the repo and that might be the issue. If your up to date with the repo give me a heads up and I'll fix it. 

Jan 4, 2013 at 1:35 AM

Sorry for late reply, I just came back from holiday. 

Yeah I just have noticed i am using the version 1.2.1.

My mistake :( 


Anyways Thanks so for such great library.

All references given in my university project report. :)